Skip to main content Skip to main navigation
Skip to accessibility page Skip to search input

Searching...

Which phones or devices can I use Google Pay with?

To use Google Pay, your device must be running on Android 5.0 (Lollipop) or higher, and support near-field communication (NFC) and host card emulation (HCE) technology. NFC and HCE are both required for Google Pay to work for in store transactions. Check the Google Pay Help Centre for more information as Google may from time to time make changes to the operating system and device requirements.